Skip to content
+1-888-319-3663

COMMUNITY FORUM

not able to access database

Scott asked 8 years ago
Just installed SmartView and have a couple of SmartList built that access SQL data tables in a different database from GP. the SmartList work fine in GP but in SmartView receive the following error: “The server principal “smartview” is not able to access the database ‘oasis’ under the current security context.” In the SmartView internal manual I ran across a note that stated that the SQL group DYNGRP needed to have access to the tables in the external database with the select right granted. So I added the SQL security group DYNGRP to the database oasis and selected the tables used in the smartlist making sure the select right was granted. Any ideas as to what I am missing in the security setup?
Answers
Best Answer
Scott answered 8 years ago
Ok fixed it. Had to make sure that the SQL user “smartview” was also mapped to the database with the database role “DYNGRP” selected. Thanks

If you would like to submit an answer or comment, please sign in to the eOne portal.