After being switched from Perpetual to SaaS subscription, most of my users were not able to log into SmartConnect 21 on-premises because they were not linked to our tenant.
Using this documentation link, I was able to add the user to the UAM account, however now I get this error message.
The User ID in the database is different from the User ID in the UAM. Please synchronize the users from the configuration tool for this instance.

How do I resolve this error?
If you’d rather watch a video explaining this, see below or click here.
This happens because the User ID (the GUID that SmartConnect uses in the database as a unique identifier) assigned during the “local user” creation no longer matches the randomly generated GUID assigned when using the SmartConnect.com document. While this method works for SmartConnect.com or adding new users who don’t exist in SmartConnect 21 on-premises, it causes issues for users who were already present.
If you are using SmartConnect 21.1.0.1567 or above, you can follow this blog article to synchronize your users from local to the eOne UAM, and the process will also synchronize the User ID GUID values locally to resolve this error.
If you still get the error “The User ID in the database is different from the User ID in the UAM” after running the synchronization process in the configuration tool, this can happen due to a bug in build 1567 caused by a foreign key error that isn’t shown to the end user during the synch process.

To resolve that issue, the easiest solution is to update to the latest SmartConnect 21 where the synchronize bug has been resolved (1635 or higher).
If updating isn’t easily possible (time to test, etc) then we can resolve the foreign key issue manually by dropping the foreign keys manually in SQL.
First, make a SQL Backup of your SmartConnect 21 database.
Next, in SSMS, find the UserFormOption table. This table is no longer used in SmartConnect 21 and should have been removed by the SmartConnect upgrade process but we’ve seen instances like there where it has not been.

Because this table is no longer used by SmartConnect 21, you could right ‘click’ the UserFormOption table and choose to Delete it and that will solve the issue.
If we take the conservative approach, we can just delete that Foreign Key causing the synchronization failure.
Expand the Keys node, and we should have a Foreign Key defined – Right ‘Click’ the FK found and choose ‘Delete’.

SQL will bring up a confirmation window and press ‘OK’ to delete this FK.
Now re-run the Synchronize Users process in the SmartConnect configuration tool per the blog article, and the process should be successful this time and the user will no longer receive this error message.
The user might need to use the “Forgot Password” link to reset their UAM password to be able to log into SmartConnect again.