Error
A user in Business Central is receiving the error:
You do not have the following permissions on TableData eOneChangeMain: Read
Cause
The SmartConnect Change Tracking Extension is installed in Business Central, and the current user is not assigned the SmartConnect Change Tracking permission set.
Resolution
Make sure all users are assigned the SmartConnect Change Tracking permission set.
There are 2 possible resolutions.
Assign the permission set to user cards
- Choose the icon, enter Users, and then choose the related link.
- Select the user that you want to assign permission to. Any permission sets that are already assigned to the user are displayed in the Permission Sets FactBox.
- Choose the Edit action to open the User Card page.
- On the User Permission Sets FastTab, on a new line, enter “SMARTCONNECT CHANGE”.
Assign the permission set to user groups
- Choose the icon, enter User Groups, and then choose the related link.
- On the User Groups page, select the relevant User Group, and then choose the Permission Set by User Group action.
- On the Permission Set by User Group page, select the [user group] check box on a line for the SMARTCONNECT CHANGE” permission set to assign the set to the User Group.
- Select the All User Groups check box to assign the permission set to all users.