Back

Error: Line ‘Sales Order’. Parameter ‘orderStatus’. Parameter set value event. Requested value ‘B’ was not found.

Published: Mar 04, 2024
Post Author Written by Ethan Sorenson

When running an import into NetSuite Transactions setting the Status requires using the display name instead of the Internal Id.

Scenario

When trying to set the Status of an Transaction record in NetSuite with the Internal Id of the orderStatus field, the integration returns an error that the Requested value was not found.

If you try to map the ‘B’ value into the Status field instead, you will not see an error, but the status will not be updated either.

Cause

The orderStatus field is a read-only field in the NetSuite API. Instead of updating this field, we need to update Status which is the underlying status field for all transactions which controls the orderStatus field.

Resolution

We need to remove the integration mapping on the orderStatus field on the integration and instead map the Status field.

You can find the status value to set by either checking the definition of the orderStatus field in NetSuite or by viewing the underlying NetSuite XML data as shown in this article.

Locate Status in the XML, and copy the value.

<source>Web Services</source>
<status>Pending Fulfillment</status>
<statusRef>pendingFulfillment</statusRef>
<storeorder>F</storeorder>

In your integration map the display value of Status into the Status field.

In my scenario I needed to map “Pending Fulfillment”.

Make sure the orderStatus field is not mapped in SmartConnect.

Feeling stuck? Get the support and guidance you need to help you power through any data challenge

We're on your integration team. Connect with our people and let us know how we can help you.