Skip to content
+1-888-319-3663

COMMUNITY FORUM

Web Client

Brian asked 3 years ago
We are using SC version 20.18.0.9.   When I attempt to log on to the Web Client the page refreshes and clears the credentials.  I tried to login using IE 10 and Chrome and got the same results.  What are the potential causes for this?
Answers
Ethan Sorenson Staff answered 3 years ago
Brian,
 
Configuring the Web Client can be tricky. You say the page refreshes and clears the credentials, but it isn’t returning any errors?
 
I would first recommend checking the config file for the Web Client to make sure the connection string is correct.
By default the file is located at the following location.
C:\Program Files (x86)\eOne Solutions\SmartConnectWebClient\Web.config
Server: SQL Server Instance
initial catalog: SmartConnect database
User: SQL User with access to the database
Password: Password for above SQL user
packet size: 4096
ImpersonateDomain: Domain of user that will be running the service
ImpersonateUsername: User that will run the service
ImpersonatePassword: password of user that will run the service
Marc replied 3 years ago

SmartConnect 20.18.1.14:

I was unexplainably getting a slightly different behavior until I tried this suggestion. And now I am getting exactly the same result (username/password is cleared when I hit Sign In button).

When I checked the web.config settings I found the Server, Password and Impersonate fields were all empty (probably due to installing the web client from the Modify option on the installer instead of during the initial install). I populated them, saved the web.config file and then restarted IIS for good measure and attempted the log in to see that now it just clears my credentials, offers no explanation or error, and resets the sign in page.

Do you have any other suggestions?

Using Chrome or Firefox I get the behavior described above and no event viewer entries hinting at why. Using IE I get an ‘anti-forgery’ asp.net error which articles I found identify as being a problem when enhanced security is enabled in IE which I am unable to turn off.


If you would like to submit an answer or comment, please sign in to the eOne portal.