Skip to content
+1-888-319-3663

COMMUNITY FORUM

The Selected User is not a valid active directory user

mscott@associates-solutions.com asked 7 years ago
Just installed Smartconnect. Tried to add a new AD user. Went to Setup -> Security. Clicked the Add User. Changed Location to be the domain. Browsed for the user I want. Found it. Clicked OK. Got back an error from SmartConnect: The selected user is not a valid Active Directory user.
Robyn replied 7 years ago

I am having the same issue. Did you find a solution?

Answers
Best Answer
mike answered 7 years ago
You need to give the user that is trying add users read permissions to any parent OUs that contain the user you are trying to add. So if your user is buried two or three OUs deep and the user you are using to add users can only see the containing OU but no parent OUs then you need to give them access to see the parent OUs as well. At least that is what fixed it for us. We did a wireshark trace to see the LDAP queries that smartconnect was sending to AD, that is how we figured it out.

If you would like to submit an answer or comment, please sign in to the eOne portal.