Skip to content
+1-888-319-3663

COMMUNITY FORUM

taCreateUpdateBatchHeaderRcd – Requires Transaction Source in GP2015

Renee asked 5 years ago
Hello!
After upgrade to GP2015, I noticed that the Transaction Source (TRXSOURC) is now required with the taCreateUpdateBatchHeaderRcd.  I am attempting to create SOP Batches so I set the TRXSOURC equal to Local Constant = Sales Transaction Entry.
However, when I run the map, I receive the following error:
Error Number = 20166
Error Description = Batch approval is not set up (REQBAPRV) in the Posting Settings table – SY02300 for this Transaction Source (TRXSOURC).
I agree with that message.  We do not have batch approvals turned on and yet I have to populate a Transaction Source.
Any ideas how to resolve this issue?
Thank you!
Answers
Patrick Roth Staff answered 5 years ago
Renee,
You would always have had to provide a transaction source – that isn’t new with 2015.  The Batch Header table SY00500 stores the batches for most of GP.  And since I can have a batch named TEST in all those modules there has to be something to differentiate the batches – and that “something” is the transaction source.
The reason you get the error is that the batch source Sales Transaction Entry is incorrect.  For SOP, it should be “Sales Entry” instead.
Or you can make it easy on yourself if that you are creating a single use batch – eConnect will create the batch for you if you don’t create it first.  So perhaps you weren’t previously populating this table or possibly you are trying to create the batch to set it to specific settings for your own reasons.
patrick
eone
 
Renee answered 5 years ago
Odd, we did not have the Transaction Source mapped in GP2010 but after the upgrade to GP2015, it now appears as a required field in SmartConnect.
I had originally put Sales Transaction Entry because I saw that as a valid choice in the SY02300 table. 
I just switched it to Sales Entry and now I receive this error:
Error Number 20165
Error Description:  You have passed an invalid Transaction Source (TRXSOURC) – it does not exist in the SY02300 table.
Thoughts?
 
Renee replied 5 years ago

I should also add we use this map to create 10 empty SOP batches. So I know eConnect would automatically create the batch if I were importing SOP Transactions, but in this case, we just want the empty SOP batches created.

Renee replied 5 years ago

And the BCHSOURC in the SY00500 table = Sales Entry but the TRXSOURC in the SY02300 table = Sales Transaction Entry.

Not sure what has changed with this new version of GP, but something is a bit off.

Suggestions welcome!

Renee replied 5 years ago

The TRXSOURC is actually blank for all of my existing batches in the SY00500 table. Is there any way to make the TRXSOURC no longer required in eConnect? It does not appear required in GP as the existing batches do not populate that field.

Patrick Roth Staff answered 5 years ago
Renee,
Whoops – my fault.  I’ve sometimes used Batch Source & Transaction Source interchangeably which is incorrect.
For your Batch Source, it should be Sales Entry.
Transaction Source IS a required field in SmartConnect for some reason – not sure why as eConnect doesn’t demand it to be set.  But it is:
Solutions to your issue:

1. Use the Node Maintenance window in SmartConnect and find the Create or Update batch that you added to your map.  Open it up and find the TRXSOURC column and unmark the “required” checkbox.
2. otherwise eConnect is expecting you to only map that column if batch approvals is activated.  Since it isn’t, you shouldn’t pass it in.
create a new calculation and return “”.
now map that calculation to the trx source field in smartconnect.
it is mapped so that satisfies the requirement that it be mapped. and it is empty so econnect doesn’t give you an error.
 
 
 
Renee replied 5 years ago

No worries! Thank you for your reply. Option #1 worked for us!


If you would like to submit an answer or comment, please sign in to the eOne portal.