Skip to content
+1-888-319-3663

COMMUNITY FORUM

Table “SC_RealTime Failed accessing SQL data

sueconrod asked 8 years ago
Just did an update on GP2010 to SP3 and updated Smart Connected to Version 20.13.0.49 or 2013 version 49. Went to this version because in test upgrades found that it went right though and didn't give me any issues. Not to be when we hit production.

After you get the above error then got "Create Table Permission in Database DYNAMICS denied"

1. Read all the articles when trying to come up with a fix and found one that noted that if you were getting a forms error it could interfer with the upgrade of Smart Connect. Sure enough had a forms error and fixed that. Basically went out to Great Plains and renamed all my previously upgraded dictionaries and then since I had backed them all up in a .pkg re-imported them.

2. Was then able to run the Upgrade.exe in the eOne Connect File.

3. Logging in GP and getting the same error and now even worse getting an error that when users went to log out that "Processes must be run to completion" except it never went away and the only way to log out was to use Task manager and kill Great Plains.

4. Then saw an very good articles from RUANN about GP2013 System Database and another one re: "Create Tables for Extender failing". Checked and only had one instance of eConnect, mark that one off as not being the culprit. But then the 2nd article said to run "Grant.sql" against the DYNAMICS and all company databases.

IT WORKED. Thank you all who contribute to the forum. 

If you would like to submit an answer or comment, please sign in to the eOne portal.