Skip to content
+1-888-319-3663

COMMUNITY FORUM

Stored Procedure Permission Error

Tat Mysayphonh asked 4 years ago
Hi SmartConnect Team,
When our user tried to run a map with a stored procedure they received the following error:   PH_APTRANSACTIONS_VALIDATE: ERROR [42000] [Microsoft][SQL Server Native Client 11.0][SQL Server]The EXECUTE permission was denied on the object ‘StoredProcedureName’, database ‘DBNAME’, schema ‘dbo’.
I updated his user role in our SQL Server to sa and he was able to run the same map without any issue.  Is there a work around we can do without increasing our user permission? 
Thanks,
Tat
Answers
Patrick Roth Staff answered 4 years ago
Tat,
You’ve defined the connection that SmartConnect is using on your map destination for stored procedure. 
So instead of using a connection with Windows Authentication, you should enter proper credentials on the destination (such as “sa”) that has permissions to any SQL objects (ie this proc) the map is using.
 
Tat Mysayphonh replied 4 years ago

Thank you Patrick for the quick response. Solved the problem.


If you would like to submit an answer or comment, please sign in to the eOne portal.