Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartView for multiple companies

Jim asked 4 years ago
We have several Smartlist Builder queries that are set to work across multiple GP companies.  In SmartList they work fine based on the company database the user is logged in to.  But in Smartview they only work under one company.  I have logged in as sa for each company and tried as well, but the results were the same.  Each time the Smartview item comes back with a sql timeout.  However the same items run through Smartlist return results in a few seconds, so that timeout message seems misleading.
Any suggestions would be appreciated.  We’re on GP2015 R2 with SV 14.0.6
Answers
Nicole Albertson Staff answered 4 years ago
There are a couple of things we would like to clarify.

  1. When you say they are set to work across multiple GP Companies, are you using the Multi-company option in the Summary window?

  2. Are these built with SQL tables, GP tables, or something else?

  3. If you run a SQL Profiler Trace with the Exception errors turned on, what is the query it is running and the error that is being returned there?


Let us know in a little more detail what you have setup and what is happening and we can try to assist from there.
Jim replied 4 years ago

No, I’m not using the multicompany option in the summary window. Each of these smartlists is built with a SQL views and those have the ‘Use Company Database’ option marked. They each also include the binary stream user facility table. That’s what I was referring to. So in smartlist I can log into the first company and run the slb to get data for that company, then log into a different company and runt he same slb to get data for that company.
I’ll run the trace and get you the answers on that part.
Thanks for the quick reply.

Jim replied 3 years ago

Hey Nicole – sorry for the long delay. I’ve tried the trace but not getting any results. SV just comes back with the sql timeout message.


If you would like to submit an answer or comment, please sign in to the eOne portal.