Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartPost generates email send errors even if email server is not configured

Alejandro asked 1 year ago
SmartPost is generating this error even if there is not email server configured:
Error emailing reports for batch : BT20301 in company : COX to :
The parameter ‘address’ cannot be an empty string.
Parameter name: address
There are this error too even if “Do not delete batch report” configuration option is not checked:
Could not delete reports for batch : BT20300
Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
Is there something to do?
 
Thank you
 
Answers
Patrick Roth Staff answered 1 year ago
This is a bug in the last few version of SmartPost 2016/2018.  When posting, the Reports that you have selected are created in the reports directly (to be emailed if necessary) and then should be deleted.  There is a bug that tries to delete the files when finished but that fails with the error noted.
This will be fixed in an upcoming service pack.
The only workaround on your version would be to either:

  1. ignore the error and manually delete the files periodically

  2. in Setup mark the checkbox for “Do not delete batch reports”.  This avoids the error but you would still have to delete them manually if you really don’t want them.

  3. turn off reports for that posting process.  If there aren’t report files generated then smartpost won’t try to delete them (and fail)


patrick
 
 
Alejandro answered 1 year ago
Hi Patrick
Thank you for your prompt response, the option of not deleting the reports is currently configured, but the error is generated anyway.
 

If you would like to submit an answer or comment, please sign in to the eOne portal.