Skip to content


SmartList Excel Export

Terry Horn asked 9 years ago
When we installed GP 2010 a couple of years ago we had issues on the Excel export from SmartList where digits were changed.  After a bit of research, we found that when SmartlistEnhancedExcelExport=TRUE there are known issues (see below).  We have several extracts that are 50,000 rows or more.  Is there a know fix for the issues outline below AND still get the improved speed?

Leading zeros are stripped from string fields when they are exported to Excel.


The last digit of a string field is changed from a ‘2’ to a ‘0’. For instance:

Without Enhanced switch:

Same record with Enhanced=TRUE

Thanks in advance for any help.


Best Answer
Nicole answered 9 years ago
There isn’t another option outside of using the SmartListEnhancedExcelExport=TRUE line in the Dex.ini to speed up the SmartList Export that we are aware of. This is a setting core to SmartList, but I haven’t heard that Microsoft has released anything different. Part of the reason it is faster is that it allows Excel to do the formatting instead of sending it through cell by cell with the formatting SmartList wants. If you are running SmartLists just to Export to Excel, you may want to take a look at using the Excel Refreshable Reports instead of SmartList. This will pull the data right into Excel instead of having to try to return it in SmartList and then Export it to Excel. Another option is to use SmartView instead of SmartList. SmartView is eOne’s version of SmartList with a lot of feature enhancements including a much quicker return of the data in general and the export to Excel is much faster. Thanks, Nicole

If you would like to submit an answer or comment, please sign in to the eOne portal.