Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartList Builder has detected changes message every time SmartList is opened

Victoria Yudin asked 8 years ago
We are on GP 2013 SP 2 (build 12.00.1482), SmartList Builder version 12.00.0270.000 build 12.00.0054 (this is the one from eOne, not MS). Every time we open SmartList, we get the message: SmartList Builder has detected changes to be made. Do you want to make these changes now? We say yes, then SmartList works just fine. But next time we launch SmartList, we get the same message again, even though no changes have been made in SmartList Builder. This only started recently, probably a week ago. We installed the eOne SmartList Builder a few months ago. I do not believe anything new was installed prior to this starting, but I am not 100% certain.
Jared replied 8 years ago

Does your slb20000 table conatain any data?  This is where changes are stored and as long as something exists in that table that message is going to show up.  If there is data in the table you could look at a SQL trace to see why it is not being removed after clicking ok. If you are logged in as the sa user does the message go away after accepting it once?   

Victoria Yudin replied 8 years ago

Thanks Jared,

So this was happening for a week…as soon as I post my question, it stops. I guess that was the fix! 🙂

If this comes back I will check the SLB20000 table and post back.

Thanks again,
Victoria

Victoria Yudin replied 8 years ago

Hi Jared,

This just happened again. I looked in the SLB20000 table and it had an entry with a SmartList_ID of .19 and a SmartList_Change_Type of 2.

When I click Yes, the entry does go away from the SLB20000 table, so it’s not sticking in there, but I suspect something is making it come back periodically.

I created all of our custom SmartLists and I would have never used that as a SmartList ID. Is this something internal in the product? Or something that would have been created automatically at some point? When I look in SmartList Builder, there is no SmartList with that ID, but I do see it in the database in SLB10100, SLB10200, etc.

Jared replied 8 years ago

Hi Victoria.  The .19 signifies that an origianl SmartList has been modified.  That would be the Inventory Transactions SmartList in this case.  Somehow that list is getting modified.  If you select modify from within SmartList and make no changes in SmartList Builder and click save it still processes it as being changed even though you may have not done anything.  If you look in SmartList Builder at that SmartList there will be an asterisk after the SmartList ID to signify that it's an original SmartList that had been modified.

Victoria Yudin replied 8 years ago

Hi Jared,

I tried this with another ‘original’ SmartList. I opened it in SmartList Builder, looked at what tables it was pulling from, but did not make any changes and DID NOT click Save. It still created a new record in SLB00100 and a few other tables. When I look at the objects in SmartList Builder, if I change the Type to Existing and look at the dropdown list, I do see an asterisk next to the one I was just testing with (Account Transactions) – however I DID NOT make or save any changes!?! The original one that is causing the issue (Inventory Transactions) is on the list with NO asterisk.

What is the best way to fix this? I would like to go back to the original out-of-the-box SmartLists for both of these.

Thanks,
Victoria

Jared replied 8 years ago

To go back to an out-of-the-box SmartList you need to select the modified list in SmartList Builder and click the Delete button and the orginal will be returned.  

Any changes will be stored in the SLB20000 table until SmartList is opened and you click yes to make the changes.  Do you have other users that could be making changes?

Victoria Yudin replied 8 years ago

Jared,

No, I would be the only user making these changes.

Following your instructions I was able to delete the Account Transactions* modified SL and I see that’s out of the tables now.

However, since the Inventory Transactions is not showing an asterisk, how do I clear that up?

Thanks again, Victoria

Jared replied 8 years ago

If you're looking at the existing SmartLists in SmartList Builder and they don't have an asterisk they aren't modified.  If you look in the slb20000 do you have anything in there currently?  If you still have the record with the SmartList_ID of .19 can you look in the slb10000 table and see what the SmartList_Name is for the SmartList_ID of .19?  If you would like to send me the results you can at jared.dux@eonesolutions.com

Randal replied 8 years ago

Same issue here, records being added to the SLB20000 table when there is no user modifying any SmartLists.  The existing Smartlists have no * on them.  They were originally using Microsoft SLB but recently converted to eOne SLB when upgraded to GP 2013.

Running SQL Profiler, the insert into the SLB20000 is from a user who was only running a Smartlist query.

Answers
Best Answer
Nicole answered 8 years ago
SmartList Builder has code it in it to update the User Defined Fields in it for the Customer, Vendor, and SOP Setup. So, anytime this setup changes, it is prompting for the change in SmartList for SmartList Builder. This will only happen though if you have a setup in SmartList Builder that is based on one of these three options, whether it be using the SmartList table type or the GP Table type. We do have a build that changes this, but will not be going through full testing if you want to give it a try, please e-mail support@eonesolutions.com. Otherwise, we will release the change in our 2013 R2 build that will release shortly after Microsoft Dynamics GP 2013 R2 releases shortly.
GinaH replied 8 years ago

I have a client who has this issue also. SLB20000 named a SLB item that is not often used. I deleted the SL. Now the message pops up again and names .19 In reading the thread I see this would be a SLB that was created from an original SL Object. They have a dozen or so SL names with *. How do I stop this message? How do I know what SL .19 is referring to? No one is making changes to any of the SL using SLB. Thank you.

GinaH replied 8 years ago

Sorry, I said the SL was .19. It's .9

Nicole answered 8 years ago
SmartList Builder was setup to update the User Defined Fields with the names if they were included in any of your SmartList Builder setups. This caused the update to happen anytime the master records were updated. We do have a new build that changes this, but will not be going through full testing if you want to give it a try, please e-mail support@eonesolutions.com. Otherwise, we will release the change in our 2013 R2 build that will release shortly after Microsoft Dynamics GP 2013 R2 releases shortly.
GinaH replied 8 years ago

Thank you Nicole. I saw this reply from you earlier in the thread. None of the SL are using UD fields. I don't know which SL .9 represents and when I query SLB10000 there is no .9 name. The SLB SL are pulling PO info and various payroll info. There are no UD fields in any of the SL. Once I deleted the SL referenced in SLB20000 the problem continued but now names a diff SL (.9). What do we need to do here? Client says this has been happening since their upgrade to GP2013 and their move to eOne SLB from GP. Thank you.

Brenda Niblo replied 8 years ago

My client is experiencing this same issue.

In looking through the SLB tables, I find the .6 and .20 smartlist ID's in several tables – from reading this thread it sounds like these are "original" GP smartlists that SLB "thinks" have been modified and are the Sales Transactions and Sales Line Items lists I believe.  We want the original versions only of these.

I think I read in the eOne manual that if we go to Smartlist Builder, select "Existing" as the type and then locate the ones with the asterisk at the end (mine are Sales Transactions and Sales Line Items), and select them and delete them, I will lose all the favorites.  That will cause a major problem for this client – they have TONS of favorites for these two lists.

So… can I simply go through the SLB tables and delete the records that refer to the .6 and .20 smartlist IDs instead?  I assume then I will NOT lose my favorites?

The tables that these are listed in are:  SLB10000, SLB10100, SLB10200, SLB10400, SLB10600, SLB10700, SLB10900, and of course constantly showing up in SLB20000 which is what is causing the "detected changes" message to pop up.

I can guarantee they did NOT make changes to these standard smartlists so if this will work to get them out of all these tables, that would be great.

Thanks.

Victoria Yudin replied 8 years ago

Brenda, what you’re suggesting (cleaning up the tables) is exactly what I did to fix the issue and we have not had any problems since.

Brenda Niblo replied 8 years ago

Thank you.  I removed the records in all those tables.

On a side note, they had also had VERY slow performance from the Sales Transactions list as well (you would select one of the favorites and you would watch it paint every line of the smartlist).  Taking these records out of the SLB tables appears to have corrected this slowness issue as well.

thanks again.

Nicole answered 8 years ago
You shouldn’t have to go through any tables in SQL to resolve the issue. If you pull up the Existing SmartList Type and then select the “modified” one with the * on it, you can delete it there. When you do this, you will need to re-launch SmartList if you had it open. The default SmartList will be back with any favorites that existed before it was modified. If one was created while it was modified, that favorite would be gone since it was on the SmartList Builder one that was deleted. We do have a fix for this and you can get it from eOne support if you would like but hasn’t gone through all of the regression testing, otherwise, a new release of SmartList Builder coming out when 2013 R2 releases from Microsoft that will include this fix. Thanks.
Victoria Yudin replied 8 years ago

Nicole,

In my case, these SmartLists were not in the list to be able to be deleted, so I had to do it from the tables. 🙂

Robert Shapiro replied 7 years ago

My client is running SLB Version 12.00.0056 They are running into the same issue. I installed the SLB lists. We imported vendors, GL accounts and GL history. Please let me know when the new build is available that resolves this issue.

Mike replied 5 years ago

Many thanks Nicole, it worked like a dream.

Jared answered 7 years ago
There is a new version available for download in the SmartList Builder downloads section  that will solve this issue.  Make sure to download the correct version of SmartList Builder according to your GP version as with the R2 release of GP 2013 there are two versions of SmartList Builder.

If you would like to submit an answer or comment, please sign in to the eOne portal.