Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartConnect to SQL duplicate rows

Greg Crossan asked 5 years ago
I have a map that pulls data from SalesForce and puts it in a SQL table, which is later used for another map.  When I preview the data there are no duplicates, an if i run the soql query in SalesForce, there are no duplicates.
However when I look at the SQL table, there are duplicates?   Where are the duplicates coming from?
Paul replied 4 years ago

I’m having this same problem with an import from Dynamics CRM. The rows should be unique in my case as well, without any grouping.

Paul replied 4 years ago

Although, in my case, I was not getting a duplicate and then I exported/imported the map to another instance.

Paul replied 4 years ago

I figured out my case. When I imported the map, I had to change the default connection for the SQL table. When I clicked the Databases button, there were two selected (what looked like my old invalid database and then correct database). I unmarked and deleted the invalid one and then it stopped duplicating.

Suresh replied 11 months ago

Paul, Thanks for this post, it helped me to solve the issue, same database checked off twice. Somehow connection retains old server name and the same database name as well. Cheers!

Ben replied 10 months ago

I had a similar issue, but only one database was selected. After deselecting that database, trying to run the map that way, receiving the error that no database was chosen, then re-selecting the same database, the data stopped duplicating.

Answers
Lorren Zemke Staff answered 5 years ago
Greg,
What are the key fields set to on the data source. Do the key fields selected make the records sent to the SQL table unique or does it have multiple records per key field? This is the first grouping that is created or basically how many documents are sent to the destination.
You may need to set the Group By option on the destination node to make sure only one record per group is sent.
Greg Crossan replied 5 years ago

The field is unique. It is opportunity id, which is a unique guid.


If you would like to submit an answer or comment, please sign in to the eOne portal.