Skip to content


SmartConnect Timeout Issues

KHowardJoslin asked 10 years ago

I'm running several SQL scripts via SmartConnect after the map runs successfully. This is something I do regularly.

However, I'm received a "timeout period has expired" message when I attempt to run this script fromt he map. The script takes about 40 seconds if executed directly from SQL.

Any insights would be greatly appreciated.


Best Answer
kevin answered 10 years ago
Hi Howard,

The solution to this issue depends on how you are running the scripts after the map has completed.

If the scripts are  VB,NET or C# scripts, check the timeout in the connection string and make sure that it is long enough for your script to run.
If the script is run through a SQL Command task then the default timeout is the default timeout of your SQL server.


Chris Hanson answered 10 years ago
If you are using scripts then there is a specific timeout you can set in the code. It would look something like what is below where I have declared a command object (named command) and then am setting the timeout property (in seconds):

command.CommandTimeout = 60


If you would like to submit an answer or comment, please sign in to the eOne portal.