Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartConnect stops working after upgrade to 2015 and GP 2015 R2

Joseph Markovich asked 6 years ago
Hello:
After upgrading to SmartConnect 2015 and GP 2015 R2, SmartConnect has stopped working.  It no longer runs any of my maps that have either a pre-step to Execute SQL or a destination of SQL Table or any GP Change maps.  These are the errors I am receiving:
– When creating a new GP change map: said the tracking table was created successfully but after I set everything up and hit save, receive an error of “Invalid column name ‘Method'”

– For the existing GP change maps — if I try and run them manually or the schedule server tries to run them automatically, the error is “Could not save record”.  There’s another error too: “not-null property references a null or transient value eOne.SmartConnect.Connectors.Microsoft.Dynamics.Gp.MsGPChangeDataSource.FilterFields.

– The triggers on some of my tables are missing: example: SOP10100, IV00101 after the GP upgrade.  I can understand this because of the changes GP has made to the tables, but System Maintenance does not put them back?
– For the existing maps that have a SQL Query step or have a destination of SQL Table, the maps successfully run, but the SQL script does not run and nothing is actually updated.
I’ve had a support case open since the beginning of January and haven’t heard anything back yet — so hopefully this will get a response on how I can fix this.
Patrick Roth Staff replied 6 years ago

For #1 and #3, you should follow up on the case to see where it is at. Perhaps we were waiting on you for a question or perhaps your issues got lost in the shuffle of cases.

For #2, I think I would agree with you. System Maintenance ought to re-register the triggers (or remove them if the checkbox is unmarked) but it doesn’t appear that SC is currently doing this.

As I noted, while I think that SC should do this – it is somewhat of a tossup if this is a bug or a feature.
But to get the ball rolling, I encourage you to enter this as a SmartConnect product suggestion.

http://www.eonesolutions.com/forum/type/smartconnect-feature-requests/

patrick

Brad replied 6 years ago

What was your resolution to the Invalid Column Name ‘Method’? I am getting the same thing…

Andy Cronk replied 4 years ago

Manually drop the smart connect tables in the GP database, re-open the map and re-choose the options (i.e. create update delete) and it creates the tracking table and triggers for you


If you would like to submit an answer or comment, please sign in to the eOne portal.