Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartConnect Scheduling

marcb@progressive-solutions.com asked 9 years ago
We recently had a scenario where the server was rebooted and the smartconnect service did not re-start successfully.  When we noticed it, we manually started the service which kicked off a large scheduled map in the middle of the day when it is normally scheduled to only run at 4 am. 

We would like to know if there is a way to force the SmartConnect scheduler to only run at it's scheduled times even if the last scheduled time was missed?
Ruaan Jonker replied 9 years ago

Hi Marc

Unfortunately that is how SmartConnect handles the scheduling.
When the service starts up it will find all scheduled maps with a “Next Run Date” that is smaller than now and run them.
The only way to get around this is by opening the schedule and saving them before the service starts. This will reset the “Next Run Date” to a future date. 

klewis replied 9 years ago

Just as an FYI, the SmartConnect Service failure to start at reboot will always happen…at least it does in my case…i have a task in place to start it upon reboot, but if you don't have that option, i would just make a mental note to check the service in the am as a normal routine if you are not aware of a reboot.

Answers
Jules answered 1 month ago

Recently, the smart connect service failed to restart after the server was rebooted. I need to buy research papers online to complete my essay. Our team noticed this and restarted the service to prevent it from being run in the middle of the day when it is usually scheduled to run at 4 am.


If you would like to submit an answer or comment, please sign in to the eOne portal.