Skip to content


SmartConnect Scheduler : Could not run the scheduled map Thread was being aborted.

Rachael asked 2 months ago

The Windows Service has not ‘stopped’ but whatever the scheduled map does completely stops processing (e.g. data uploads), and the activity is not removed from the MapActivity table so unless we go in and manually delete the activity and restart the service processing will never resume.  SmartConnect does not know the map has failed or stopped, so we have no way of sending a notification when this happens.

This is an example of what gets logged on the machine where the Windows Service is running:

SmartConnect Scheduler : Could not run the scheduled map MY_MAP_NAME Thread was being aborted.

As far as I can tell there is nothing logged on the Dynamics CRM server, turning on tracing and leaving it running for days waiting for a failure is not an option here. I get the same error when attempting to run manually outside of the schedule.  We are able to run very long running data imports on various other maps without issue.  No other scheduled maps are impacted.

Has anyone seen this before or does anyone have any suggestions as to what we can do to remedy it?

Patrick Roth Staff replied 4 weeks ago

This happens because your map is running longer than the configured timeout setting that the scheduler users to make sure maps don’t run forever.
The default timeout is 240 minutes.
If you say “yeah but my maps do run for 6 hours” – then you just need to adjust the timeout using the smartconnect config tool – eOne.SmartConnect.config.exe

The setting is the “Windows Service Thread Timeout” and will likely be set to 240 (default). Just change it to whatever (think max is many days – in minutes of course) and the configuration tool will restart the service (or you can after wards).


If you would like to submit an answer or comment, please sign in to the eOne portal.