Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartConnect Mapping Doubling GP Transactions

Justin asked 4 years ago
I am using the SmartConnect E1_Excel_GL_Journal entry Excel map with an Excel sheet that has the following information:



BATCHID
TRANTYPE
TRANDATE
SRCDOC
CURRID
REFRENCE
ACCOUNT
DEBIT
CREDIT
DISTREF
KEY
REVERSEDATE
COMPINTERID


Works
0
05/01/17
GJ
Z-US$
Test
10-1000-1001
100
0
TEST ONLY
1
01/01/00
COM


Works
0
05/01/17
GJ
Z-US$
Test
10-1000-1001
0
100
TEST ONLY
1
01/01/00
COM



When I run the SmartConnect map, I get the following errors. I get the Record Count equaling ‘4’ and one error count.
The error is “Processing filed for data rows matching KEY = “”, then when I go to GP to see the Purchasing Batch, the transaction is set to double the amount in the Excel file.
 
Answers
Lorren Zemke answered 4 years ago
Justin,
The record count is based on your Key Field selection. That tells SmartConnect how many unique documents to generate. If the record count says 4 then there are 4 unique values in the Key field.
The error about Key = “” means that you have some empty/blank values in your Key Field(s) which would represent one of those 4 documents.
You will also want to set the Group By option on the Transaction Header node to the same fields as your Key Field(s) to make sure the correct number of journal entries are created based on that grouping.

If you would like to submit an answer or comment, please sign in to the eOne portal.