Skip to content
+1-888-319-3663

COMMUNITY FORUM

SmartConnect GP Tables Missing

janakirammp asked 8 years ago
Hi

Smartconnect installation went well. I'm getting an error while trying to add GP Real time Data Source Invalid object name 'DYNAMICS.dbo.SC9000'. I realized the tables are not showing up in DYNAMICS. I ran the process for resource cache. It didn't work. 
lorren replied 8 years ago

Can you expand on what you mean when you say it didn't work?  The resource cache never completed?  Or it completed but didn't create the SC9000 table?

janakirammp replied 8 years ago

Hi

I get the message maintenance completed but it fails to create any table

janakirammp replied 8 years ago

Hi

any luck on this one?

Thanks

Answers
Best Answer
Chris answered 7 years ago
You need to make sure you run 2 processes. The first needs to be done within the main SmartConnect interface and is called System Maintenance.

The second is the Resource Cache that is run from inside of GP that has the SmartConnect dictionary installed on it.

For the first process, you want to ensure you are logged into SmartConnect as an admin and have setup a user in the GP Connector with power user rights (like sa). When logging into GP for the second process you also want to use the sa account.

This will ensure those processes are running under an account with enough rights to create any missing objects.

H
Terry Dickens replied 6 years ago

I’m getting this same error.

On System Maintenance in SmartConnect interface I get this error: Error: Microsoft Dynamics Gp- An error occurred while Re-Registering ‘Real Time Event’ ‘Update’ for ‘Connector ‘SmartConnect Dynamics GP Connector”: Invalid object name ‘SC9400’.

In GP in the Create GP Resource Cache, I get this error: [Microsoft][SQL Server Native Client 10.0][SQL Server]Invalid object name ‘DYNAMICS.dbo.SC9000’.

Any ideas on what to try?

Akber answered 2 years ago
I am really sad that how come the product is published on website without testing it. This is kind of really going worst that you download the software, installed and then it did not work at all. I have many errors first when Launch the smartlist from the Tools menu
[Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid object name ‘DYNAMICS.dbo.SLB10000’.
Next the cache didn’t work and throw these error
[Microsoft][SQL Server Native Client 11.0][SQL Server]Could not find stored procedure ‘DYNAMICS.dbo.zDP_EXT90101L_1’.
[Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid object name ‘DYNAMICS.dbo.EXT90101’.
 
 

If you would like to submit an answer or comment, please sign in to the eOne portal.