Skip to content
+1-888-319-3663

COMMUNITY FORUM

SeSecurityPrivilege error on map

Eric asked 3 years ago
We have a map that is using an Excel sheet and is setup as:
Data Source Type: Bulk Data Load
Data Source: Folder Data Source
 
As soon as you drop a file onto the “Source Folder” the below error is visible in Event Viewer
General:
Map:<Map Name>-The process does not possess the ‘SeSecurityPrivilege’ privilege which is required for this operation.
 
Details:
– System 
  – Provider 
   [ Name]  eOneSmartConnect 
   – EventID 0 
   [ Qualifiers]  0 
    Level 2 
    Task 0 
    Keywords 0x80000000000000 
   – TimeCreated 
   [ SystemTime]  2018-09-06T05:59:57.543196000Z 
    EventRecordID 3753 
    Channel SmartConnect 
    Computer <XXXXX.XXXX.com.au>
   Security 
– EventData 
   Map:<Map Name>-The process does not possess the ‘SeSecurityPrivilege’ privilege which is required for this operation. 
 
In the SmartConnect Activity window, the Map will then be visible and with a Lock Type of “Service”
As it is locked, the files are not imported.
 
Deleting the SmartConnect Activity sometimes allows the maps to run.
This is on 20.18.1.11
 
Any assistance would be appreciated.
Thanks.
Eric
Answers
Ethan Sorenson Staff answered 3 years ago
Eric,
This error message is a windows permissions error. When I google that error message I find a lot of errors referencing user accounts not having access to file locations without it.
Make sure the account assigned to the SmartConnect Windows Service is a local machine Admin. In particular, this user needs the ‘SeSecurityPrivilege’ 
Eric replied 3 years ago

Hi Ethan,

Thanks. But yeah the account is a Local Admin, and the Service Account as well. The account also has Full Permissions to the folder drop location

Could my issue be related to the bug mentioned on https://www.eonesolutions.com/discussion/the-process-does-not-possess-the-sesecurityprivilege-privilege-which-is-required-for-this-operation/ ?

Thank you Ethan!

Eric replied 3 years ago

I think you may be referring to the Manage auditing and security log, mentioned on the msdn blog. I have attempted to test that as well, but the issue is still visible.

As soon as you drop the file the event viewer shows the error, and I am unable to run the map

Any assistance would be appreciated.

Lorren Zemke replied 3 years ago

Eric, Are you using the Real-Time option for the folder data source? Typically, it is the scenario that the map won’t fire when using the real-time option but it is never such that it gives this error. This SeSecurityPrivelege error is always windows communication and not anything in Smartconnect.

Eric replied 3 years ago

Hi Lorren,

Not the Real Time one.

We have a map that is using an Excel sheet and is setup as:
Data Source Type: Bulk Data Load
Data Source: Folder Data Source

Thanks

Eric

Eric replied 3 years ago

Hi Ethan/Lorren,

Looks like I may have fixed this after digging a bit deeper:

1. Even if the eOne Service Account was a Local Admin, I explicitly added it to the below Local Security Policies permissions

Back up files and directories
Debug Programs
Manage auditing and Security log
Restore files and directories
Take ownership of files or other objects

I do think this is a bit much. But these were mentioned on a different blog around SQL.

2. Deleted and recreated the schedules
3. The below error was then visible

There was an error writing to the pipe unrecognized error 232 (0xe8)

Ran the fix on https://support.microsoft.com/en-us/help/2539263/error-message-there-was-an-error-writing-to-the-pipe-the-pipe-is-being

4. Restarted the eConnect Integration and eOne SC services

So far it appears to be working.
Will update this should anything change.

Thanks.

Eric


If you would like to submit an answer or comment, please sign in to the eOne portal.