Skip to content


Scheduled maps stopped running – watched folder

Pieter du Toit asked 4 years ago
Hi.  I have a number of maps that uses the watched folder method.  They are all scheduled to run every 5 minutes.  Over the last few days, they stopped working.  The schedule still runs and the maps run fine when I do it manually.  The services are started and I rebooted the server.  We are on the latest version.  
When I look at the event log, I get this message (not sure if it means anything):
The description for Event ID 0 from source eOneSmartConnect cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
If the event originated on another computer, the display information had to be saved with the event.
The following information was included with the event:
SNGL_JRNL_REV: Unable to remove blank lines: The source contains no DataRows.
The handle is invalid
Ethan Sorenson Staff answered 4 years ago
If a map works correctly when run manually, but not when scheduled it is usually a security issue. Here are some recommendations for finding the root cause.
1. Open the map and go to the ‘Options’ tab. Make sure the box for ‘allow any user to run this map’ is checked. Also check the box for ‘Return map success’ is also checked.
2. make sure the user assigned to the schedule service has access to the folders used in the map. If possible, log into windows as that user and try to run the map manually.
3. Make sure the user assigned to the SmartConnect Windows Service is a local machine administrator, and is an administrator in SmartConnect.
4. Make sure your map is using UNC pathnames to all folders.
5. Make sure the files in the source folder have the same format as the file being used as a template.
If you are still unable to fix the map, I recommend emailing

If you would like to submit an answer or comment, please sign in to the eOne portal.