Skip to content
+1-888-319-3663

COMMUNITY FORUM

Scheduled Maps do not run – SC Service is hung

Joseph asked 4 years ago
 
For a while (random as of now)I have noted that a scheduled map has not run and the window in Mgt. Console does not have it showing as coming up. I check Activity but it is not currently running either.  
 

 
 At that point I use the Services MMC to restart the service but it errors out that the service has not responded to the stop request in a timely fashion. Refreshing the Services window will show the service as “Stopping”. At this point the only recourse is to Kill the process. When I restart it, all the missed scheduled maps will start running right away. There are no abnormalities in the SmartConnect log. 
 

 
 Any ideas here ?
 
Patrick Roth Staff replied 4 years ago

Sounds like the service is hung up internally if it isn’t running maps and then seems “busy” since it isn’t responding to a Stop service event like it should be.

You don’t mention your version but SC 2016 had this type of issue. I would recommend that you update to SC 20.17.0.17.

Joe Powers replied 4 years ago

I did update, hoping it would fix the issue, but it did not. Running 20.17.0.17 and it still happens

Philip Kluss replied 4 years ago

Joe,

You’re not crazy. i have the latest and the scheduler is awful. Memory leaks, orphaned activity, and more mean you can’t trust it to actual perform the task.

Answers
Joseph answered 4 years ago
I did update, hoping it would fix the issue, but it did not. Running 20.17.0.17 and it still happens

If you would like to submit an answer or comment, please sign in to the eOne portal.