Skip to content


Scheduled map fails, but is successful when run manually

asked 11 months ago

Hello, I have maps that if it’s kicked off by the scheduler fail with the error “There was no endpoint listening at net.pipe://localhost/Microsoft/Dynamics/GP/eConnect/EntityOperations that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present for more details.”

When I run these maps manually they run successfully with no issue. I created all of the maps, and set the schedule. I checked the eConnect service and it’s running and I tried updating the password just in case but still get the failures. 

For all the maps the data source is a query that uses ODBC, that works fine when I preview and when I run it manually. One map does warehouse assignment to items, another imports and inventory adjustment and the 3rd imports an inventory transfer.

Would greatly appreciate any assistance as this is holding off some important automated processes.


Thank you,


Boris replied 10 months ago

Just thought I would update this, a restart of the SQL/Application server and the terminal server seemed to have fixed this. The restart was unrelated to the jobs and not sure which of the servers restarting fixed the problem but something to note.

If you would like to submit an answer or comment, please sign in to the eOne portal.