Skip to content


Scheduled Map Doesn’t Run

inksplatter asked 8 years ago
Any idea why a map would run perfect when executed manually versus being executed on a schedule? I have 2 maps. One that imports orders, another that imports payments. They both execute 100% perfect individually if I manually click the run button. I have the payment map as a task to run after the order map. It doesn’t seem to always run. So then I tried to set up the payment map as a scheduled map. It doesn’t run either on the schedule. I’m not getting any errors. I have the map setup to email me on fail. I don’t get any emails (unless it fails when I manually click the run button). The order import map is set to run on a schedule and that map runs fine on the schedule.
Best Answer
lorren answered 8 years ago
If you look at the SmartConnect Event Log on the machine where the eOne SmartConnect Windows Service is running, what errors do you find in there?

inksplatter replied 8 years ago

Thank you for your reply.

SmartConnect Scheduler : Could not run the scheduled map MAGE_SOP_PAYMENT_IMPORT You do not have access to the connectors required for this map.

inksplatter answered 8 years ago
I was able to get it to run now by checking the “Allow any user to run this map” box under options. Thank you!
lorren replied 8 years ago

The other option is to make sure the user assigned to the Windows Service is an admin in SmartConnect so any scheduled maps will be able to be executed without an issue.

If you would like to submit an answer or comment, please sign in to the eOne portal.