Skip to content
+1-888-319-3663

COMMUNITY FORUM

SC 20-12-2-36

jppowers asked 9 years ago
I hate having to upgrade SmartConnect, it NEVER just works afterward. We are preparing to upgrade to GP2013 so I had to upgrade SC from SC2012 SP1. Everything was working on SP1 just fine. I uninstalled the old version as in the instructions. Installed the new version. Launched GP and processed the resource cache. It finishes with "maintenence complete" but then hangs GP and has to be terminated with the task manager. Real time maps from CRM2011 to GP are working, Change maps from GP to CRM2011 & all bulk maps are working but I can not get the real time maps from GP to CRM2011 to push any data. I used the knoledgebase entry to diagnose. The webservice is set up properly, I can browse to SmartConnect.asmx as in the instructions, registered and unregestered the maps more times than I can count. Logged into and out of GP multiple times. No entries in the event viewer on the machine running the databases and web service. Uninstalled and reinstalled 4X now. An upgrade should not cause this much pain. Can I please get some advice here?
Ruaan Jonker replied 9 years ago

Hi JP

Is GP and SmartConnect running on the same machine?
If not you will need to re-install the GP Real Time components on the Great Plains machine.

When upgrading SmartConnect you need to make sure all components of SmartConnect is upgraded. i.e. SmartConnect main install, Great Plains Real Time components, Web Service and every machine that runs the SmartConnect Service.

Please make sure the latest version of the addin is installed. (C:Program FilesMicrosoft DynamicsGP 2013Addins)

Please also see the following knowledge base article: http://eonesolutions.com/Support/Knowledge-Base/Knowledge-Base-Article.aspx?articleid=207

Reagrds,
Ruaan

jppowers replied 9 years ago

Hi Ruaan

SmartConnect, GP and SQL all on the same box. I have other GP clients using SC also, but I want to get it working on the server 1st. Installed the server install and the GP2010 components. I will check the addin, where can I find out which is the most recent. I went through the KB article you cite. It did not help. The change data sources and bulk datasources are working, just not the real time. Please can you suggest further troubleshooting steps. Thanks

     JP

kenhepworth replied 9 years ago

Hi JP,

First off with the add-in, check in the C:Program Files (x86)Microsoft DynamicsGP2013AddIns and make sure it is eOne.SmartConnect.GpAddin2013.dll

I was just wondering also if you could just check this to see if the real-time update is actually triggering. In the RealTime data source definition get the table name. Go to your company database now and go to that table and open up triggers and confirm that the trigger has been created for that realtime data source.

Regards
Ken

jppowers replied 9 years ago

Hi Ken

The add in is actually "eOne.SmartConnect.GpAddin2010.dll" with a date modified of 2/25/2013 12:08PM. Version is 20.12.2010.36.

We are preparing to upgrade to GP2013, have not done it yet as the GP-CRM connector has to work when we do.

As for the SQL Triggers, the table in question is Item Master, IV00101. The Triggers are:

MRP_IV00101_Delete
MRP_IV00101_Insert
MRP_IV00101_Update
tr_SVC_Item_Ext_U
tr_SVC_IV00101_D
tr_SVC_IV00101_U
zDT_IV00101U
aagTR_IV00101Del
aagTR_IV00101Ins
ASI28040TriggerIV00101
mfg_update_location_update
mfg_remove_orphaned_records
mfg_add_matching_item_records

    J. Powers

kenhepworth replied 9 years ago

Hi JP,

Sorry it has taken me a while with this reply.

There have been a couple of issues discovered with that build of SmartConnect. Can I suggest of actually uninstalling that SmartConnect and downloading and installing the 20.12.2.38 build and possibly giving it another go.

Ken 

jppowers replied 9 years ago

Hi Ken

I uninstalled the earlier version and reinstalled the new version. Also yesterday we upgraded to GP 2013, so I installed it with the GP2013 check box selected and Econnect checkbox selected. With this new version I am now at least are getting errors in the SC event log, so the map is triggering, but now I am getting entity lookup errors. I will investigate more today.

More significantly the maps from the CRM 2011 to GP that were working are now broken. In the error log I am getting :

GP_ACC_RT: Could not load file or assembly 'Microsoft.Dynamics.GP.eConnect, Version=11.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

The version of Econnect that the installer installed is 12.00.1307.000 It looks like there more issues here.

     Joe P

Ruaan Jonker replied 9 years ago

Hi Joe

Can we schedule a time to sit on this issue?
I am in Australia so afternoon your time will be the best.

Please contact me at ruaan.jonker@eonesolutions.com

Thanks,
Ruaan

Jeanenne Turpin replied 8 years ago

I am getting the same error message, although I am still on GP2010 with eConnect 11. I just upgraded SmartConnect 2012 to SP2.

Could not load file or assembly 'Microsoft.Dynamics.GP.eConnect, Version=11.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Any ideas?

Robinson replied 8 years ago

I am having the same issue where
GP_ACC_RT: Could not load file or assembly 'Microsoft.Dynamics.GP.eConnect, Version=11.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

The version of Econnect that the installer installed is 12.00.1307.000 It looks like there more issues here.

I am running the service on one box and the GP Client and SQL are on a different server.

Any ideas?

Answers
Best Answer
Ruaan Jonker answered 8 years ago
Hi

Open the Microsoft Dynamics GP connector setup and make sure the correct version of GP is selected in the drop down. When SmartConnect calls eConnect it will call the correct dll according to this setting.

So if you have GP 2013 installed and this drop is set to GP 2010 SmartConnect will try to use the GP 2010 eConnect dll's instead of 2013.

Regards,
Ruaan

If you would like to submit an answer or comment, please sign in to the eOne portal.