Skip to content
+1-888-319-3663

COMMUNITY FORUM

Same Repeating Error: Distribution Line = Transaction Type – GL

Angela Tolbert asked 6 years ago
I have performed maintenance. I have deleted my entire mapping, and then re-mapped everything. I continually get this error: 
 
Processing failed for data rows matching DistributionLine = “TransactionType” = AcctString…
Any ideas? Thoughts? Help? Do I even need a Distribution Line for my GL if we are only using the bare minimum in Microsoft Dynamics GP? I was informed the previous company who attempted to deploy this program did NOT use this line. However, my research shows this needs to be utilized. Any and all advise would be greatly appreciated. 
I am using .xlsm file for data source (Excel 2010), SmartConnect 2014, and Microsoft Dynamics GP 2013. HUGE SENSE OF URGENCY.
THANKS!!
Answers
Lorren Zemke Staff answered 6 years ago
Angela,
That error means that your Data Source Field(s) DistributionLine and TransactionType have blank values. SmartConnect cannot process blank values defined as key fields unless you have SmartConnect 20.15.0.51 which has an option to ignore blank Key Fields.
You can set the option on the Map Setup -> Options tab to ignore lines with Blank Key Fields and you will not receive those errors but they will not be integrated either.
http://www.eonesolutions.com/Manuals/SmartConnect/SmartConnect%202015/?page=smartconnect_map_setup_options




If there are blank lines in the data source:








o
Do nothing – do not check for blank lines in this map (default)








o
Exclude blank lines – exclude any lines that are completely blank.








o
Exclude blank keys – exclude all lines where the key fields as defined on the map are blank.




If you are creating GL Transactions you would have to use distributions or there would be nothing to post in General Ledger.
 
Lorren
Angela replied 6 years ago

Thank you! However, now I am getting: “Unable to remove blank lines: Object reference not set to an instance of an object.” So, I assume I need to remove Transaction Type from the map altogether? THANKS!

Lorren Zemke Staff replied 6 years ago

The best option is to actually delete the blank rows in your Excel file then SmartConnect doesn’t need to try and remove those blank rows which is the original issue. I can’t comment on removing the Transaction Type from the map as it may be needed.


If you would like to submit an answer or comment, please sign in to the eOne portal.