Skip to content
+1-888-319-3663

COMMUNITY FORUM

Run Map: Error in MsGpDestination. Line taGLTransactionInsert___1 for update of Global Rolling Column

dcomber asked 8 years ago
Hello, 

I upgraded to SmartConnect v2013 and everything seems to okay, but I am having an issue with one particular user (an admin user) in terms of running maps. They are receiving the following message when running G/L-Transaction maps via the SmartConnect client:

Error in MsGpDestination. Line taGLTransactionInsert___1 for update of Global Rolling Column. Could not retrieve the next number in the sequence. 

When I run this exact same map, the same way, my process runs without any errors. Could this be a client install issue? Should I just uninstall/re-install the client on this users machine? Any other ideas? 

Thanks,

Dean
Michelle replied 8 years ago

Just a thought… Is the user a member of the DYNGRP in SQL?

dcomber replied 8 years ago

Hi Michelle,

If you are referring to the DYNAMICS database, the users is not. I have only GP SQL logins in this group with the exception of our domain GP service account. Both users do not exist in DYNGRP, but user can process the maps fine via the SmartConnect client while the other user gets this error. Any other ideas? 

Michelle replied 8 years ago

No, I don’t mean dynamics, I mean SQL. Change their user is SQL to be part of the DYNGRP. A lot of the stored procedures wont run unless they are part of the DYNGRP. Can you test just for giggles? I am not sure this is the answer, but I just created a custom node that I needed to grant to the dyngrp in order for it to be executed. The GPRollingcolumn is a stored procedure written by EOne and I would expect that either they have that statement or it is inherited from the econnect stored procedures they are calling. The maps utilize smartconnects login and admin rights. Again…. Just checking

Michelle replied 8 years ago

And you kind of answered the question when you said they weren’t in Dynamics…. and by default not a member of DYNGRP. GP users are automatically added to the DYNGRP. Like I said, this is just a hunch.

Answers
NICOLE MCLOUTH answered 2 years ago
I am having the same error. I duplicated a map, and then changed the company it’s mapped to and the company for the rolling column, but I am still getting the same error.

If you would like to submit an answer or comment, please sign in to the eOne portal.