Skip to content
+1-888-319-3663

COMMUNITY FORUM

Receivables transaction not using default tax schedule

Eric Lott asked 2 years ago
When importing transactions to a receivables batch, The transactions are not using the default tax schedule set up in GP. I’ve tried setting the Tax Schedule field in SmartConnect, but it is still not working. The map runs with no errors, there’s just no data in the Tax field.
In GP, when I create a transaction under a specific customer, it uses the default Tax Schedule associated with that customer to calculate tax and add a distribution for the tax payable in that transaction. Is this not the case with SmartConnect? What are my options?
Answers
Patrick Roth Staff answered 2 years ago
Is this not the case with SmartConnect?
The ONLY document type in Microsoft eConnect (the underlying business logic that drives GP documents) that calculates tax for you is the SOP Trx node – so any kind of SOP Order/Invoice/etc.
So your RM Trx Invoice document is calculating “correctly” in that it doesn’t calculate the taxes for you
What are my options?
Two options that I can see:
1. Using the ‘add tax’ node on the map, YOU figure out the tax data amounts and then add the tax details yourself directly using that node.  It’ll write the tax lines for you with the amounts you specify.
2. Write your own “default taxes” node in a SQL stored procedure.  Then add it to SmartConnect like any other node and it’ll show in the maps.
Have it run before the Create sales transaction node so that it creates the tax records that way that the ‘create sales transactions’ will create the correct rm sales distributions for your tax records.
 
Eric Lott replied 2 years ago

Perfect, thank you for the fast response. Just did a quick test using your first method and it’s working.


If you would like to submit an answer or comment, please sign in to the eOne portal.