Skip to content
+1-888-319-3663

COMMUNITY FORUM

Query timeout expired

John asked 6 years ago
Hello:
When attempting to open a SmartConnect map, the end user gets an error message saying, “Query timeout expired”.  Normally, the fix is to open the eOne.SmartConnect.Config.exe file.  But, on this client’s machine, that file does not exist.
What do we do to eliminate this error?
Thanks!
John Ellis
Answers
Lorren Zemke answered 6 years ago
John,
The changes to the eOne Config file are only used by eConnect when sending data to Dynamics GP. If the error happens on map open it would be due to connecting to the data source and the map running that query. If it’s a SQL Server query you will need to adjust the timeout available within SQL Server.
Lorren
Jim replied 4 years ago

We’re experiencing this from time to time for some of our maps. The remote query timeout setting in sql is the default, 600 seconds. If I run the query from the map directly in ssms it completes in less that 10 minutes. Any other options?

Patrick Roth Staff replied 4 years ago

You must be on SC 2016+ and can open the eOne.SmartConnect.Config.exe.config file and adjust the CommandTimeout in the config file to a larger timeout value and you’d be ok.

Arnold Doyle replied 3 years ago

Hi Patrick
I am experiencing the same issue where SmartConnect is executing a stored procedure as a post success task. I have changed the timeout to 6000 seconds, but still get the timeout issue.
Any help is much appreciated.


If you would like to submit an answer or comment, please sign in to the eOne portal.