Skip to content
+1-888-319-3663

COMMUNITY FORUM

Problem executing mapping using GP as destination

Ezequiel asked 4 years ago
Hi! I have a problem trying to execute a mapping between CRM Query (Source) and Microsoft GP (Destination). First of all i did these steps:
 
1) I set up econnect in GP
 
2) I set up GP Connector in SmartConnect
 
3) I ran System maintenance in SmartConnect
 
4) I created a new mapping with this information: 
 
Source: Bulk Data load – Crm Query (i selected 3 fields just for test)
 
Destination: Micrososft Dynamics GP -> Group “Receivables” -> Node Type “Customers”
 
Then i mapped the 3 fields that i had selected in CRM.
 
 
 
But when i ran the Mapping for only one record the proccess was too slow and after several minutes i get this error message:
 
“Connection Timeout expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgment.
 
This could be because the pro-login handshake failed or the server was unable to respond back in time. The duration spent
 
while attempting to connect to this server was – [Pre-Login] initialization=0; handshake=0; “
 
 
By the other hand i tried to execute SQL sentence running eConnect manually and that worked. So the problem is not eConnect or the GP Instance
 
 
Could anybody help me with this? I don’t know if it’s my mistake or there is a problem with the SmartConnect
 
 
Thanks in advance!
Answers
Ethan Sorenson Staff answered 4 years ago
The issue was the eConnect windows service didn’t have a user assigned. After assigning a domain user account that was part of DYNGRP in SQL the map completed without error.

If you would like to submit an answer or comment, please sign in to the eOne portal.