Skip to content
+1-888-319-3663

COMMUNITY FORUM

PM integration fails for specific vendors

Michelle asked 7 years ago
A muli-company payables management integration was created in the test environment and tested against all databases. The integration actually runs to maps, one to update and create vendors and then one to push the payables records in. It was slowly rolled out to use with specific databases. When one specific database was started to be used there was only one vendor and that record always failed. In testing the failure, the same file was run through the test environment and successfully integrated. Now, there are more vendor records and they all consistently fail for this on database but successfully integrate in the same database in the test environment. I created a simple Payables integration with distributions to test if there were issues with the stored procedure and the records were created successfully. I restored a copy of the live database to the test environment and the records failed, I restored the test database back to the test environment and they ran succsessfully. After much ado, I re-ran my simple Payables integration (in the live database) but changed the vendor id to one where the records were consistently failing and it failed. It is throwing errors 349 and 700 – saying that an input variable contains a null value – taPMDistributionCreate.

When I utilize a different vendor id and all of the other information is the same, the record integrates successfully.

Now, I realized that upon the initial failure, when I tested the record in the test environment, I had to manually enter the vendor and had done the same for the few others that I had tested. But in live, all of the vendors were created via a Smartconnect Map

This Vendor map is also a muti-entity integration and is updating and inserting vendor records for all of the other databases without issue.

Any thoughts on what would be making these particular vendor ids through this errror in just this one database?
Answers
Best Answer
Michelle answered 7 years ago
Posted in wrong forum.  Reposting in SmartConnect.  Sorry

If you would like to submit an answer or comment, please sign in to the eOne portal.