Skip to content
+1-888-319-3663

COMMUNITY FORUM

[ODBC Driver Manager] Data source name not found

abs asked 8 years ago
I installed SmartConnect on the client's test environment and when trying to connect to Excel 2010 as source file I get the following error message –
ERROR [IM–2][Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified.

Any suggestion to resolve this ASAP?
Answers
Best Answer
sueconrod answered 8 years ago
Go to your Connector Setup and check the Server.  I'm sure you are going to find that it is pointing to your old data source.  Change it to the test enviornment.  Then go to Maintenance and your connections and make sure that the new source is listed.
abs replied 8 years ago

This is fresh install of SmartConnect and had not been imported from any other environment. In reality source file which are .txt or .csv is working fine and imported without any errors into GP. This is when I try to open Excel 2000 or higher version of Excel that I face this error.

dfeenstra@manercpa.com replied 8 years ago

Is the client running 64bit Office?  It needs the 32bit Office drivers.

DHolmes answered 8 years ago
It is possible to install the 32-bit ODBC drivers on a machine with 64-bit office.  The problem is explained in this article with key points being the redistributable file to download, and the install tip.

http://blog.codefluententities.com/2011/01/20/microsoft-access-database-engine-2010-redistributable/

To summarize, first you must download the 32-bit version of the accessDatabaseEngine file at http://www.microsoft.com/en-us/download/confirmation.aspx?id=13255 and run this from the command line using the ‘/passive’ flag to allow GP to connect to the spreadsheet.

Thanks

Dusty
GPondel answered 8 years ago
I had the same issue with office 2010 64 bit installed.  To elaborate on DHomes post I did the following:

1- Download 32-bit version of AccessDatabaseengine
       1A- http://www.microsoft.com/en-us/download/confirmation.aspx?id=13255
2- Place download in your desired directory
3- Install 32bit driver in passive mode
      3A- You will get an error if you try to install the 32 bit driver by double clicking it
      3B- You need to open the command line (Start–>Search–>cmd)
      3C- type in the path to the AccessDatabase Engine you downloaded then space /passive
       4C- Example: C:GPSharedSmartConnectAccessDatabaseEngine.exe /passive

I had to do some testing to get the proper command line prompt and wanted to share with everyone.  Thanks for pointing me in the right direction DHomes.

If you would like to submit an answer or comment, please sign in to the eOne portal.