Skip to content
+1-888-319-3663

COMMUNITY FORUM

Node taPMTransactionInsert not found

Yeffer SIerra asked 9 years ago
Im triying to create a PM invoice, the map is ok, but when i´m runing it the information windows generate the error: "Node taPMTransactionInsert not found in PM transaction type. The element node is required for this transaction type". I´m tried to reinstall econnect and update to the last version, execute smartconnect system maintance and check if the taPMTransactionInsert procedure already exists in the fabrikam database, but the problem was not solved. I'm using MD GP 2010 SP3, any idea?
Mick Egan replied 9 years ago

Check your source data first, maybe have blank records.

Mick

Answers
Best Answer
Chris Hanson answered 9 years ago
This error occurs when you have the data grouped wrong in the map. You need to have your key fields set and the transaction node grouped so that it only occurs once in every document you send to eConnect.

If you run the map to file and open up one of the records it generates, you should be able to see if that header node is there at all, or is present too many times and then adjust your mapping accordingly.

H
Yeffer Sierra answered 9 years ago
The problem was by special characters in the document number.

If you would like to submit an answer or comment, please sign in to the eOne portal.