Skip to content
+1-888-319-3663

COMMUNITY FORUM

No add option on Real-Time Data source Type

Kevin asked 6 years ago
I have an issue that when we try and add a real-time data source, the only option along the top is “Linked Maps”, and I don’t see a way to “Add” a data source. Is there something I need to do to enable this?
We are on version 20.15.0.51
Addy replied 3 years ago

I have the same problem ? how can I do fixes this ?

Answers
Patrick Roth Staff answered 6 years ago
Kevin,
under Maps | realtime data sources, there should be a drop down for Realtime Data Source Type that you can select your type of data source.
once you select that, it would show the existing ones (which you wouldn’t if just starting to set it up).  There should be an Add and Delete button to the left of the Linked Maps button.
if you don’t have these, it might be that you aren’t set up as Admin.  Or the other possibility is that the GP Connector user doesn’t have permissions to create the tables/triggers that these types will need to create.
patrick
Kevin replied 6 years ago

Patrick, Thanks. There is no option next to “Linked Maps” for either Add or Delete. I am setup as an admin user. The GP Connector user is ‘sa’. Any ideas?

Kevin replied 6 years ago

I tried to go through SmartConnect maintenance and “Re-Register Real-Time Triggers”. I noticed in the “Details” section, these references to Real-Time data sources:
Real-Time Data Sources Deregistered.
Deregistering Real-Time Data Sources…
Microsoft Dynamics Gp Real-Time Datasources Upgraded.
Upgrading Microsoft Dynamics Gp Real-Time Datasources…

Why would it be Deregistering them?

Patrick Roth Staff replied 6 years ago

1. “Any ideas? “
never run into this. only thing I can think of is the font size setting.

http://www.eonesolutions.com/help-article/kba-01111-g2p6v7/

2. “Why would it be Deregistering them? “
because maintenance unreisters the triggers then re-registers them again. there is a checkbox to do that or not.

Kevin replied 6 years ago

I checked the font setting, and it isn’t that, I have tried “running as administrator” and everything else I can think of but still don’t get the option to add a real time data source. This is really frustrating where this is a key functionality of the product, and yet, we can’t use it.

Maureen answered 4 years ago
To create a real-time data source, select the data source type (SQL or CRM), then click the Create button in the ribbon.  (Same button you’d use to create a map).  
 

If you would like to submit an answer or comment, please sign in to the eOne portal.