Skip to content
+1-888-319-3663

COMMUNITY FORUM

Map Plug-in cannot connect to the server anymore after Excel 2013 upgrade

@GP_Beat asked 6 years ago
I’ve used the Excel Add-in for quite a few months with my Excel 2010 and it worked flawlessly..
About a month ago, our IT started to deploy Office 2013 and I chose to keep my Access and Excel 2010 as it is possible when doing the installation.. Glad I did, because with Excel 2013 the add-in doesn’t work anymore… for files/maps that have no problem in 2010, I cannot seem to make it run without getting a server-connection error… Also, the toolbar for eOne has added quite a few more icons and honestly, I’ve tried every to validate the connection to my SC server, but to no avail… When trying to connect with my domain ID to the SC server, I cannot validate the URL I used to have in my old 2010 Excel config sheet : http://172.30.10.34:5556/SmartConnect/SmartConnect.asmx
Does the Excel 2013 need a different URL to connect ? has something changed in the authentication method ?
Thanks for providing a hint on how I can get my maps run again… Also when trying to run the maps with Excel 2010 and the SC Add-in, it opens the same file with Excel 2013 and executes the map with the saved data, which is very weird and dangerous, in case I’ve done some data input changes on Excel 2010 and not saved yet the file..
Answers
patrick answered 6 years ago
The Excel 2013 Addin uses the WCF Web Service and not the old asmx one that 2013 did.
The SmartConnect documentation discusses setup & configuration of the Excel addin
http://www.eonesolutions.com/Manuals/SmartConnect/SmartConnect%202014/?page=smartconnect_excel_addin_2013
patrick
 
@GP_Beat answered 6 years ago
Hi Pat,
Thanks for the reply… that’s what I have figured out too… because the document says “Excel 2013 uses the SmartConnect WCF REST”, but honestly how do I validate if this is setup on the SC web site side… ? Is there a special configuration I need to do in order to allow the Excel 2013 add-on to be able to connect ? I tried to enter the URL as it is indicated in the help file, but without much sucess… when pressing the ‘validate’ button, it returns an error message.
Where can I locate the exact URL for the WCF REST service on IIS 7.0 ?
patrick replied 6 years ago

You might not have it installed – it doesn’t by default.

Per the SC documentation, you can verify your web services in IIS

http://doc.eonesolutions.com/smartconnect/smartconnect_wcf_rest_service_install.htm

@GP_Beat answered 6 years ago
Thanks Pat,
I’ll have a look into the WCF setup, as it doesn’t look to be installed right now.. :-(. Will post an update soon.
@GP_Beat replied 5 years ago

Hi Pat,
I’ve taken up again where I left SC last year :-)… now with SC 2016.. unfortunately WCF is all installed correctly and my Map works 100% from the SC console.. but trying to run it from Excel directly with the plug-in does nothing.. Everything is configured and validate, but nothing happens when I click on the RUN button.. Any hints where to look for ?
my WCF url looks like this : http://srv-camtl-gpdbg:5557/smartconnect.svc/

Patrick Roth Staff replied 5 years ago

i cannot envision a scenario where nothing at all would happen. you press the button, you should get a return good or bad.

also i’d make sure i was installing the Excel 2013 addin that in the zip file of the sc 2015 (not 2016) install.

@GP_Beat replied 5 years ago

Thank you Pay,
I’ve downloaded the excel addon separately from the package and it is the 2013 version.. Everything seems to work, except the Validate & the Run buttons.. Is there a way to enable a trace or log file?

Patrick Roth Staff replied 5 years ago

not in the addin, no.

@GP_Beat replied 5 years ago

Thanks Pat… but there got to be a way to enable a ‘debugging’ mode in SC 2016 ? I can’t believe that you will sti in front of a software that does nothing and you can’t figure out why…

@GP_Beat replied 5 years ago

Hi Pat,
I went into my Excel 2013 Add-ins management and looked at the Excel 2013 plugin for SC… I found something strange in the path that was pointing to the DLL for the add-in, as the it contains 2 \\ instead of only 1. I tried to removed the Add-in within Excel and wanted to re-add it, but then the system complained that this was not a valid Office plugin…

Patrick Roth Staff replied 5 years ago

If you can see the eOne menu then the plug in is pathed and loaded correctly.

@GP_Beat replied 5 years ago

yes.. but the only way to add it back is to re-run the setup tool for the Excel 2013 plugin… Going the traditional way within Excel Options doesn’t work.. why ?


If you would like to submit an answer or comment, please sign in to the eOne portal.