Skip to content
+1-888-319-3663

COMMUNITY FORUM

Map errors after upgrade

MacPDX asked 8 years ago
We are receiving errors on some maps after upgrading to the latest version. Some maps work and some don't.

This is the error received:

"Could not load file or assembly 'Microsoft.Dynamics.GP.eConnect, Version=12.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified."

eConnect version is 12.00.1488.000 as listed in installed programs on the GP server.
SmartConnect Version: 20.13.1.89
SmartConnect Dynamics GP Connector: 20.13.1.89 for GP 12

We are also using NodeBuilder.


Answers
Best Answer
MacPDX answered 8 years ago
This problem has been resolved.

SmartConnect is running on a server other than the GP SQL Server.

eConnect was up to date on the GP SQL Server, so any maps that went through web services, like scheduled maps, were working. But, eConnect was not up to date on the SmartConnect server, so maps manually run would not work.

If you would like to submit an answer or comment, please sign in to the eOne portal.