Skip to content
+1-888-319-3663

COMMUNITY FORUM

Login Failed for User

Lydia asked 7 years ago
I created a new company within GP.
I logged into our test server and into SmartConnect.
I pointed the map to our new company and used the sa account to connect to it.
Now when I try to run the map, it says:  Cannot open database.  Log in failed.  Log in failed for user 'user'

I don't know what' missing. 
–I'm logged on as that user on the server
–I'm logged on into smartconnect as that user
–The login user has access to the new database with SmartConnect Setup
–The login has access rights with GP to the new company as well as the default company that SmartConnect is set to
–I ran system maintenance to correct if there are any issues

I don't know what's causing the error.

NOTE:  I've also logged in as a different user on the server as well from the PC and I still get the same error "Cannot open database.  Log in failed.  Log in failed for user 'user'"

What's missing?  What's causing this error?
Answers
Best Answer
Chris answered 7 years ago
The error is coming from the user running the eConnect service on the machine you run the map from. Since all integrations run through that service when going into GP, it uses that account running the service to call the correct eConnect nodes/procedures.

So the user running the service needs to be in the DYNGRP role for the Dynamics database and all the company databases. I am guessing it is missing that for the new company.

H

If you would like to submit an answer or comment, please sign in to the eOne portal.