Skip to content
+1-888-319-3663

COMMUNITY FORUM

ItemNumber leading 0s dropped on preview and as well as Inventory transfer destination

Jothikrishnan Narasimmaraj asked 2 years ago
Im trying to create an Inventory transfer transaction from an excel source. Item numbers has leading 0s, but I see in the preview that it dropped the leading o. and also it fails when trying to run the map saying item site combination does not exist as it dropped the 0s. What could be the reason. 
 
Version: 20.17.0.17
GP: 2016 r2 
Answers
Ethan Sorenson Staff answered 2 years ago
Jothikrishnan,
 
You will need to edit the Excel file so these columns are read correctly. If you add an apostrophe before the number it will be read as text so the leading 0s won’t be dropped.
 
For example: ‘000789
Jothikrishnan Narasimmaraj replied 2 years ago

Ethan,

Thank you! Excel column was formatted as Text and I see green mark on the cells where there is leading 0, but just SmartConnect not reading it correctly. Adding ‘ to 100s of items manually I think is not a feasible option and if I try to use excel formula then it counted as extra char.

I’ll go with importing into SQL table and try to upload, but would be nice if it is addressed in SC.

Thanks,
Jothikrishnan

Ethan Sorenson Staff replied 2 years ago

Jothikrishnan,

You won’t need to add the apostrophe to the items in GP, just to the items in Excel, and the driver will read the data correctly. This is an issue with the Excel drivers that SmartConnect uses to read data. All leading zeros need to be preceded by an apostrophe, otherwise the driver guesses what the data type is.


If you would like to submit an answer or comment, please sign in to the eOne portal.