Skip to content
+1-888-319-3663

COMMUNITY FORUM

IRemoteInterface not defined

Matthew asked 7 years ago
Just updated to the latest SmartConnect, and created a new map to copy change data from GP 10 to CRM 2013 Online. When I run the map I get an error “Type ‘IRemoteInterface’ is not defined” during compiling document processing assembly phase. Got the same error when trying to create a calculated field. The same map used to work on the older version. Any ideas? (probably an installation issue)
Chris replied 7 years ago

I would double check and ensure that .net 4.5 is installed properly as that is one of the newer requirements from the last few builds that have been released. You can also look at the manual online and make sure the pre-reqs are met as well for the OS and such.

Also look in the ScriptNamespace table in the SmartConnect database and let me know how many entries/rows of data you have in there.

H

Matthew replied 7 years ago

.net is installed properly and all pre-reqs are met (Windows 2008R2 + SQL 2005)
ScriptNamespace table contains:
System
System.IO
System.Windows.Forms
System.Data
System.Xml
System.Data.SqlClient
eOne.SmartConnect.Engine
which is consistent with the documentation.

Answers
Best Answer
Matthew answered 7 years ago
Turned out this error related to some bad data in the SmartConnect database after the upgrade. A fresh install and manually re-entering the maps solved the problem.

If you would like to submit an answer or comment, please sign in to the eOne portal.