Skip to content
+1-888-319-3663

COMMUNITY FORUM

Installation Error: Could not write value ScSqlPassword to registry

CJ asked 6 years ago
Hi,
I am trying to upgrade my current smart connect version to the latest release.
After I select all the components, and enter in the credentials, it gets through 90% of the installation until it needs to write values to the registry and then it fails with the following error message.

Could not write value ScSqlPassword to key \Software\eOneSolutions\SmartConnect. Verify that you have sufficient access to that key or contact your support personnel.

I opened regedit.exe and went to the HKEY_LOCAL_MACHINE and added the ‘everyone’ group and gave them full access permissions. I also went to the exact location mentioned above, and verified that the everyone group had been added to it.
I am also running the installation as administrator, I am logged on as an administrator.
This is on a Windows Server 2008 R2 Standard 64-bit.
Previous SmartConnect version is 2014.1.25
I am attempting to upgrade to 2015.0.47
 
Any help would be appreciated!
 
CJ replied 6 years ago

*Update* I also tried adding the domain admin account that I was using directly to the permissions in the Registry, still no success.

Answers
CJ answered 6 years ago
Alright, it looks like I had two problems.

  1. Since I was Upgrading the Smartconnect user somehow lost permission to access the smartconnect database, so I changed the properties so it had full access.

  2. I changed the SQL password for the SmartConnect User. 


After doing both of those changes I was able to install without issue.

If you would like to submit an answer or comment, please sign in to the eOne portal.