Skip to content
+1-888-319-3663

COMMUNITY FORUM

Install SmarConnect for 2018

Lavan Reddy asked 2 years ago
Hello,
I installed smartConnect 2018 on windows 2016 server on client. Installed DB and User Interface. It was successful but when i opened the SmartConnect UI. I see this error
https://ibb.co/dQ6fLcj
 
Answers
Patrick Roth Staff answered 2 years ago
Either you modified the smartconnect config file manually after installing SmartConnect or else somehow on the install the items aren’t encrypted as they should be.
Could be this:
https://www.eonesolutions.com/tech-thursday-smartconnect-and-windows-platform-fips-encryption-policy/
I don’t recall what I wrote but if you have FIPS enabled and install SmartConnect, then SC will add the entries in non-encrypted.  But then SC fails to read them on launch as you are seeing.
The solution is to implement the settings from the article (by changing SC settings or else disable FIPS) and then launch the SC Configuraiton Editor in the SC folder and re-enter the creds.  That’ll get properly encrypted this time and can be successfully launched.
patrick
Lavan Reddy replied 2 years ago

Hello Patrick Thank you for your response. We have FIPS enabled. I created those config files, it doesn’t work. My error is different though. It is about not a valid Base-64-string. Here by providing the error again

https://ibb.co/Cw5jwrj

I was setting up these two items on GP client server. I verified that Framework 4.7.2 is installed on the server.
SmartConnect Database
SmartConnect User Interface

E-Connect was installed, but was on GP webserver though. I am not sure if this was the reason for the failure, but even in our current system (GP 2015), E-connect was on webserver and client server has smartConnect.

I see that DB was created, but when i open the SC, seeing this error

Patrick Roth Staff replied 2 years ago

It does work, I tested and wrote the article and tested this very scenario.

If you open the eOne.SmartConnect.Setup.Config, you’ll see that the “EncryptedProductionSection” is likely plain text and not base64 text. That is the error that SC is giving you on launch.

If you implement the config files from the article and then run the configuration utility (eOne.SmartConnect.Config.exe) and re-enter the server & credentials, it will be encrypted properly when you save & exit the application.

And SC will be able to read the newly encrypted settings and then also work around the FIPS with its own config file.

Lavan Reddy replied 2 years ago

Hello Patrick, Thank you for your response. I copied these 3 files
eOne.SmartConnect.Config.exe.config
eone.SmartConnect.RunMapConsole.exe.config
eOne.SmartConnect.UI.External.exe.config.
to C:\Program Files (x86)\eOne Solutions\SmartConnect

I launched eOne.SmartConnect.Config.exe and provided the same details as what is in config file but the test connection failed. I verified in DB that SmartConnect user is created and has DBO rights to the DB.

I tried logging into DB with user smartConnect through SSMS, it didnt work. I manually changed the password for that user in DB and logging through SSMS worked. I provided the connection details on eOne.SmartConnect.Config.exe and test connection worked but when i clicked save and got this error
https://ibb.co/DfSh7GM

Lavan Reddy replied 2 years ago

Hello Patrick,

Thank you it worked now. I opened the eOne.SmartConnect.Config.exe as Admin, but still wondering why the password was not correctly set during installation.

Patrick Roth Staff replied 2 years ago

Because due to FIPS enabled, the SC install couldn’t properly encrypt the passwords. And instead of just completely failing, the install then wrote the information into the config file as plain text.

So that piece worked fine, however the SC applications don’t expect plain text to be in the config file and blows up because of that.

The only recourse then is to redo the connection per above with the config settings added beforehand so that the encryption is properly used.


If you would like to submit an answer or comment, please sign in to the eOne portal.