Skip to content
+1-888-319-3663

COMMUNITY FORUM

Inaccessible logs: Security

Julie S asked 8 years ago

Hello, 
I am trying to run a map from a workstation and I am getting the following error: 

The source was not found, but some or all event logs could not be searched. To create the source,
you need permission to read all event logs to make sure that the new source name is unique. Inaccessible logs: Security.

I am able to run the map directly from the SQL server.  The windows user I am logged in as is an administrator
on this box and has the same security as on the SQL server.  I am also a SmartConnect administrator.  I am able to preview
my source file in the SmartConnect mapping.  I checked the Event Log on the box and it is showing the same error message under
Application and Service Logs > SmartConnect.  I need to be able to get this (and my other mappings which are getting
the same error) to run from this workstation as the end user does not have access to the SQL server. 

Thank you for any help.

Answers
Best Answer
Hanson answered 8 years ago
The log it is complaing about is the Security log in the Event Viewer. Windows requires the user that creates any new log in the event viewer (in this case it is probably trying to create a SmartConnect or eConnect log) to have access to all the others.

The user it should be using to try create this is the account that is running eConnect on that machine. Open up the windows services and find the eConnect service and check the user on there and re-enter their credentials. What we have seen on a couple machines is that the user is saved something like administrator@eone.com rather than eoneadministrator which causes the security check to fail.

H

If you would like to submit an answer or comment, please sign in to the eOne portal.