Skip to content
+1-888-319-3663

COMMUNITY FORUM

Ignore processed order

Taek asked 5 years ago
We created an order in CRM and integrated using a map I created in smartconnect. The order was processed and posted in GP. We created another order in CRM and when I ran smartconnect, it was trying to bring in the old order as well. That order (old one) failed due to being a duplicate (yay!!!) but how can I just set it so the map ignores the orders previously integrated? I don’t see a ‘ignore’ check box
There are 3 nodes that I mapped:
Create/update item
Add line item
Create sales transaction
 
Ethan Sorenson Staff replied 5 years ago

Hello Taek,
What are you using for a data source type? If you use changes only, it will only bring over the orders that have changed.
The following link will have additional details on setting up a Change Table.
http://www.eonesolutions.com/Manuals/SmartConnect/SmartConnect%202015/?page=smartconnect_mssql_change_data_source

Ethan

Taek replied 5 years ago

Hey Ethan,
I’m using MS CRM query as my database. I’ve updated CRM order as fulfilled/completed so the query should be refreshed, no?

Patrick Roth Staff replied 5 years ago

Taek,

SC IS re-running the query every time you run the map (as you’ve noticed).
If you want to restrict out records, you’d have to modify your query by adding restrictions that would filter out these fulfilled/completed – SmartConnect isn’t going to do that for you. How would it know you wanted to do that?
If you cannot restrict out the records on the initial CRM query, you could also create a Restriction in the mapping and restrict out any data for any reason that you want so SC won’t re-process it. It is more efficient to do this on the query/server side vs the client side but both would work.


If you would like to submit an answer or comment, please sign in to the eOne portal.