Skip to content
+1-888-319-3663

COMMUNITY FORUM

How to resolve “no endpoint listening”?

Casey asked 8 years ago
I'm receving the following error after submitting a JE Upload template directly within SmartConnect

There was no endpoint listening at net.pipe://localhost/Microsoft/Dynamics/GP/eConnect/EntityOperations that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. 
 
When I submit the JE from within Excel, I get a dialog box with an explanation point and an OK button, that's it.


Answers
Best Answer
Casey answered 8 years ago
An incorrect password was the underlying problem.   Problem solved.
Julie S replied 8 years ago

I'm getting this same error message on a user's computer.  But the integration on the server works just fine.  Which password did you find to be incorrect?

Lorren replied 8 years ago

Julie,

Chances are the eConnect Service is not running so it's possible the user assigned to that service has an incorrect password or it may be that service is not running on the machine with the error.

Go to Administrative Tools->Services and look for the eConnect service.  Of course this assumes you are on GP 2010 or 2013.

Here is a knowledgebase article on the process.  http://support.eonesolutions.com/Support/Knowledge-Base/Knowledge-Base-Article.aspx?articleid=152

Lorren

@GP_Beat replied 5 years ago

the URL of the link is broken and ends up in a 404 page..

Holly replied 4 years ago

Lorren – you are one of my favorite techs hands down! Whenever I have a problem, I can count on you to have an answer posted that will lead me to a resolution!
After an upgrade, I got this message. When looking at the eConnect service, I found both a problem with the user rights that was referenced AND that the service wasn’t running. You gave me clues to BOTH problems in one fell swoop.
Thank you!


If you would like to submit an answer or comment, please sign in to the eOne portal.