Skip to content
+1-888-319-3663

COMMUNITY FORUM

Group On not working for GL transaction

Paul asked 7 years ago
I am attempting to integrate GL transactions with SmartConnect, but appear to be having some trouble with the Group On functionality. I am using the same source for the header and detail, but grouping on some fields for the header.

For testing purposes, I am integrating 4 detail records, which should group to 2 header records. However, when I run the map, it attempts to send 4 transactions, causing all to fail because they are (obviously) unbalanced.

I have verified that if I run the group-by statement in SQL, I get only two results. Also, I am not using any fields in the Destination Columns that are not marked as Group On in the Source Columns. Finally, I have the Group data checkbox marked.

Am I missing something?
Answers
Best Answer
lorren answered 7 years ago
Paul,

The Key Field setting on the Data Source is your initial grouping and determines how SmartConnect will process the header/detail nodes together.  Setting the Key Field to how many journal entries should be created.

On the Header Node, set the group by to the same fields as you have set for the Key Fields.

On the Line Node, do not group any fields.

This blog article may help.  http://eonesolutions.blogspot.com/2013/04/tech-tuesday-smartconnect-key-fields.html


Lorren

If you would like to submit an answer or comment, please sign in to the eOne portal.