Skip to content
+1-888-319-3663

COMMUNITY FORUM

GP Rolling column

Florence asked 7 years ago
Hi folks,

Was trying again with my GL entries over smartconnect. Had many concerns about the GP Rolling Columns.

First of all: is it possible to make it work with multicompany? When you create a rolling column, it asks to select a company. But if we want to make it work for documents using multicompanies?

My 2nd question was about the GL entries themselves.When you post GL entries, you wanna have 2 lines: one with a credit and the other one with a debit. So i was using 2 lines per transactions in my excel sheet. How could I make it works with rolling columns? Because both lines for the same transaction should have the same GL number.

If anyone has tips and tricks to share about how I could make this work properly, would be very much appreciated! 🙂

Regards,
Flo
bmoore replied 7 years ago

Question 1: I would not say this is the official way to do it, but I set the rolling column off of one company and when we use multiple companies SC seems to translate it to the company is it loading to.   
 
Question 2: They need to add a column to the document they are loading from that distinguishes the journal entries and have smart connect us it as a grouping.  For instance our JE''s are grouped by BATCH NUMBER first and the JOURNAL NUMBER second.  All lines for the first entry would have a 1 in that column all lines for the second entry would have a 2 etc.
 
Compliments of my co-worker who uses SC extensively

Florence replied 7 years ago

Hi!

My coworker also showed me how he managed to make this work. Well, at least for the (2). With my own knowledge of SC, I have an idea of what I'm going to do. Need to test it.

For the (1) multicompany, he never tried it so I'll make some test and see if it works as you said. Else, I have ideas of stuff I could try to make it work.

I'll spend afternoon trying to make this work and will just give my own solution just in case someone is digging for the same thing. So hard to find out doc around the Internet, we rely on that little community to survive ahahaha! At least, we'll become SC pro! 😉

Thanks for your help!

Regards,
Flo

Florence replied 7 years ago

Hi,

It doesnt work for the multicompany.

In fact, the rolling doesnt work at all. I've tried using only one company and I always get an error.
[quote=]Error

Error in 'MsGpDestination'.
Line 'taGLTransactionLineInsert___DB9C7357-33F1-4454-B669-A28100D97778'.
Parameter 'Journal entry number'.
Parameter set value event.
Could not get next number for Journal entry number : Could not retrieve the next number in the sequence.

[/quote]

Just mentionning for "company" I've defind a < return _COMPANY > (var coming from my excel file and needed to make multicompany works). Any hint?

Regards,
Florence 

Florence - Ultra FT replied 7 years ago

Hi there,

Here is news from my problem.

So, tried without multicompany. Now my problem is this one:

[quote=]Error

Node taGLTransactionHeaderInsert not found in GLTransactionType.  The element node is required for this transaction type.[/quote]

Searching trought forum, found someone with that error message and someone suggested it could be the grouping. Currently, i'm trying to insert 2 GL entries. But someone said that we should only have ONE entry else eConnect won't work. Modified my grouping to have just one record in prreview and this time map runned fine. Well fine, yes it worked but it didnt do what I want….

Currently, I have 4 lines in my excel files. Those 2 lines are 2 GL entries (2 lines = 1 line for credit and the other one for debit). So in the end, what I want is having 2 GL entries with both a debit and a credit distribution. Nothing more nothing less. But sounds like it's not possible to add more than 1 gl entry at time with a rolling column….. Like… it can only return one GL number and nothing else. Is that right?

So I need those expert of SC that are roaming around to help me out. How can I insert multiple GL entries with diffrent GL # in one run of a map using the GL rolling column? is that possible? Any suggestions? Thanks in advance to those who will take time to reply! 😉

Regards,
Florence
(Ultra FT)

Answers
Best Answer
Patrick answered 7 years ago
Florence, You should be able to have as many journal entries as you wish in your data. I’m working with a partner right now on a case in that he has about 6500 2-4 line GL entries in the source data. The error you are getting happens because you didn’t group your data. So right now SC only sees the individual lines. So find something that only the transactions that should group together as one JE. In my example I posted recently on the eOne blog, the GL transaction (using a GP Rolling column) was 3 lines grouped on TrxDate. http://eonesolutions.blogspot.com/2014/07/tech-tuesday-smartconnect-addin-office.html I just re-tested it by copying the same 3 lines and changing the date. Now I imported 2 GL Trx with 3 lines each with their own unique JE for each. Patrick eOne
Florence answered 7 years ago
Hi again!

Started to mess around with the SC trying to make it works with static GL numbers, then multicompany, then the GP rolling column…

I seriously rolled back to my first set up by now and now it works… But I have all the same parameters than before… I don't understand what's wrong with this software but this is not the first time it's doing this. Very frustrating. Lost couple hours working on something that should have work as it was earlier. Blah.. Too bad…

So just saying that you were right bmoore. My rolling column is set for a company but when I have to write inside the other company it automaticly swtich and get the good GL number just as you said. Nothing to do. In fact, the parameter to chose company (when you set up the rolling column) is totaly useless. You can set it up to whatever you want, in the end, the smartconnect will be smart enough to know which company you're looking for.

So yes, don't know why it didnt work previously but I really rolled back to my first set up and now it works… very strange…

Getting back working on this. If i keep going i'll be an expert before end of summer! 😛

Happy pre-friday all!
Thanks to live chat support for their help too!

Regards,
Florence
Ultra FT
Florence replied 7 years ago

Hi Patrick,

I was typing my answer at same time as you did yours.
So as stated in my message, for reasons I can't explain, it was not working, I tried many things to make it works and then I got back to my previous build and now it works. I dont understand why now and not earlier. This is really annoying… But at least it does work.

I was not understanding myself why it didnt want more than one entry at time previously because this is not the first time I was working with SmartConnect and GL entries.

So I guess this is another mystery of computer science! 😉

Thanks for your reply anyway! Have a great day.

Regards
Florence


If you would like to submit an answer or comment, please sign in to the eOne portal.