Skip to content
+1-888-319-3663

COMMUNITY FORUM

GP 2013 System Database

Geoff Harding asked 9 years ago
Instead of getting the actual eror messages when importing data into GP2013, I get the  following message for each error line:
Database 'DYNAMICS' does not exist.  Make sure that the name is entered correctly.

My install of GP2013 is such that I do not have a system database of that name, but it is called something else (this is a new ability in 2013 to allow multi-tenancy).  If I add a database with that name and retry the import, I now get messages that table taErrorCodes doesn't exist.  Basically it looks like SmartConnect is always looking for the DYNAMICS database for the error message table rather than using the system database I defined in GP.

I would assume that SmartConnect would use the system database I specified when setting up the GP connector (it is an option on that window called Dynamics DB Name), but it seems it is not.  Is there another setup option for me here, or am I doing something else wrong, or is this a bug in SmartConenct?  I am on SmartConnect 20.12.2.40 (the latest).


Regards,
Geoff Harding
Ken.Hepworth replied 9 years ago

Hi Geoff,

A quick thing to check might be going into the map and checking the query to confirm whether 'DYNAMICS' is used within the query. If it is, change this to the name of the new name and attempt to execute the map.

I hope this helps.

Regards,
Ken

kenhepworth replied 9 years ago

Hi Geoff,

Sorry about that, I was not thinking straight and gave you some wrong advice.

When you installed, if you did choose your alternative name in the Dynamics DB name that should be OK, but it seems as though something has possibly gone wrong there.

Can I suggest that you try uninstalling and reinstalling SmartConnect one more time to see if this might tidy things up, but the only other might be to talk to eOne support directly, because it sounds as though something may have gotten mixed up a bit and talking through things directly with them might solve it quicker.

Regards,
Ken

Geoff Harding replied 9 years ago

Actually I have already tried reinstalling twice, so that is not the issue.

Is there anyone from eOne that monitors these forums that can confirm this is a bug and/or suggest a fix?

Thanks,
Geoff

Lorren replied 9 years ago

Geoff,  We do monitor the forums but they are designed for the community at large.  However, we'll get this tested and verified as an issue for development.   Thanks, Lorren

Ruaan Jonker replied 9 years ago

Hi Geoff

We do not have DYNAMICS hardcoded anywhere in SmartConnect anymore.
Please ensure that you run System Mainetanance after setting up your GP 2013 connector.

Regards,
Ruaan Jonker
eOne Solutions

Geoff Harding replied 9 years ago

I am pretty certain there is something in SmartConnect that is referring to DYNAMICS.

I have never had a DYNAMICS database on my GP2013 install, at least until I tried diagnosing the issue. I have tried using my own nodes as well as GP nodes and both have this issue. There is no doubt that when an error occurs on a line, it is looking for the DYNAMICS..taErrorCodes table.

I tried totally removing the SmartConnect database, uninstalling etc. and starting everything from scratch. I still get the problem of the system looking for the DYNAMICS database for errors when using stored procedure nodes for importing.

Regards,
Geoff

Ruaan Jonker replied 9 years ago

Hi Geoff

SmartConnect does not reference the taErrorCodes table at all.
We call eConnect which runs the stored procedures and if it failed tries to find the corresponding error message in the Dynamics database.
Can you please check that you have the latest version of eConnect 2013 installed and that the 2010 service isn’t running.
 
Thanks,
Ruaan

Answers
Best Answer
Geoff Harding answered 9 years ago
Success!

I have both eConnect 2010 and 2013 services on my box, my it seems you can only have one running at a time.  Of course it chooses 2010 to start first, so 2013 was not running.

I have set 2010 to be manual and started the 2013 service and it all works nicely.

Thank you, Ruaan.

If you would like to submit an answer or comment, please sign in to the eOne portal.