Skip to content
+1-888-319-3663

COMMUNITY FORUM

folder data source issues

sid jayawardena asked 8 years ago
I'm using SC 20.13.0.49

I have an integration using the folder datasource 

1) When I click create schema, change some default field types and hit save, the schema.ini does not get created correctly – the following is all there is in the schema.ini file

[MANBIL.csv]
ColNameHeader=True
Format=CsvDelimited
MaxScanRows=5000
CharacterSet=OEM
 

2) When I run the integration, it says no files were returned even though there is a file there. The filename is CDS Courier Testing201310.csv so there are no special characters in the filename. There are also no file locks on the file itself.

I have tried this using a UNC and a path on the SC computer itself

sid jayawardena replied 8 years ago
BUSINESSUNIT,PARTICIPANTCUID,BILLTYPEID,BICURRENCYCD,TARGETINVOICE,SERVICECODE,UNITOFMEASURE,DESCR,QTY,UNITAMT,TAXCD,TAXEXEMPTFLG,TAXCDVAT,VATTXNTYPECD,VATAPPLICABILITY,GROSSEXTENDEDAMT,FROMDT,TODT,PACKSLIPNO,BILLOFLADING,PRODUCTKITID,SETID,PROCESSINSTANCE,USERID,ADDDTTM,BIDISTRIBSTATUS,LINENUMBER
DCS01,TEST,DCC,CAD,,4400A,,ATON Setup,1,317.5,,,,,,317.5,31-Oct-13,1/1/1900,,,,,0,,,,1

PS This is the file I'm trying to upload so as you can see no special characters in it either
sid jayawardena replied 8 years ago

Ok, I figured out the issue #2 (no data returned) – the file had an extra blank column

(I love the error messages by the way – very descriptive. For this problem, for
example, the file was just left in the source folder and the error message was "No data returned")

I am still having problem #1 where the schema.ini doesn't get created


If you would like to submit an answer or comment, please sign in to the eOne portal.