Skip to content
+1-888-319-3663

COMMUNITY FORUM

Extender Import Successful, no Data

Amanda asked 7 years ago
Good afternoon, I am importing 4 columns into Extender and it is successful but I have no data in the end. Here is the process. Exported data via SQL Query, Deleted all data via SQL Query, Added the new data to the Exported data into the Excel Document, Converted it to CSV (tried both Tab and Comma), Used Extender Imports, Set up the fields and file type fine, Import is successful but when I go to the record or in SQL there is no data still Keep in mind I am not trying to update the data, I did remove it all first. I have a Number Field (A), Date Field (B), List Field (C) and List Field (D). I removed the data from Field C and D and it still didn’t work. All of field A gets transferred. Therefore my conclusion is that field B is the issue. I have tried 6 different Date Data Types on this and still nothing in that field will transfer. (tried yyyy-mm-dd, month dd, yyyy, mmddyyyy, mm/dd/yyyy, yyyy-mm-dd 00:00:00.000, yyyy-mm-ddThh:mm:ss) EXT01112 has date1 data type as DateTime so I tried yyyy-mm-ddThh:mm:ss still nothing. What am I missing here? Thanks, Amanda
Answers
Best Answer
Nicole answered 7 years ago
When importing a date, I tried 5 different formats from an Excel Spreadsheet. 6012013 ’06/02/2013 6/3/2013 ‘06042013 6/5/2016 12:00:00 AM The two options that worked are ’06/02/2013 and 6/3/2013. The first is seen by Excel as text because of the apostrophe in the beginning. The second was entered as 06/03/2013 and the date functionality of Excel auto formatted it to 6/3/2013. This was a post we also had previously from another customer that worked for them on dates: “I found a solution that seems to work (for me at least) and is easy to implement. If you right click on the date and go to Format Cells>Date, the Excel default date format of *03/14/2001 was used. The explanation for the * is given below the date options but it basically means that it uses your computer

If you would like to submit an answer or comment, please sign in to the eOne portal.